I have been troubleshooting micaToolbox v2.2, because I cannot get my files to open when I am generating an mspec image. Instead of loading the directory window for me to select a photo, I get this error:

Error: File open error

“/private/var/folders/l5/v61lc2297358vp5r8xxjzs140000gn/T/AppTranslocation/2D1B91B7-8365-4431-BD25-5ACBE2A0A34C/d/ImageJ.app/plugins/micaToolbox/importSettings.txt (Read-only file system)”

in line 211:

dataFile = File . open ( settingsFilePath <)> ;

I am able to load a raw image using DCRAW import, and I have changed the file permissions for the micaToolbox plugin to execute, so I’m not sure why it doesn’t work when I try to generate a mspec. I get the same error with the Photo Screening tool.

I have tried updating everything and restarting my computer and making all the files executable. I am working on a M1 Mac in Monterey. Is there any other troubleshooting I can try?

file permission error when generating multispectral image
jolyon Answered question June 16, 2023